Home > Error Cannot > Error Cannot Find Libpq-fe.h

Error Cannot Find Libpq-fe.h

no Ruby can't find the relevant setting of the PostgreSQL installation. What are the drawbacks of the US making tactical first use of nuclear weapons against terrorist sites? If you have problems with gcc, please look into the stackoverflow link - thanks Asad. Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the this contact form

Inserting a DBNull value in database Why was Gilderoy Lockhart unable to be cured? Can Tex make a footnote to the footnote of a footnote? Hopefully this helps someone avoid a bit of head scratching when searching for the "-dev" package on a FreeBSD system! note: anytime you change the bash config - changing profile.d config - you should reload the bash.

Already have an account? Draw an ASCII chess board! What is the bandwidth cost of running a full node? ¿Muestra la imagen un ejemplo de signo tironiano? Terms Privacy Security Status Help You can't perform that action at this time.

Train and bus costs in Switzerland TreePlot does not give a "binary-looking" tree for a binary tree Is the NHS wrong about passwords? share|improve this answer answered Jul 30 '14 at 3:46 lucianosousa 3,17331117 How did you install postgres? If it exists, it will be in the include directory of your Postgres install. $ locate libpq-fe.h /Library/PostgreSQL/9.1/include/libpq-fe.h The bin directory, which contains pg_config will be in the same directory as How do hackers find the IP address of devices?

yes checking whether we are cross compiling... Wrong password - number of retries - what's a good number to allow? If building fails, please try again with --with-pg-config=/path/to/pg_config checking for libpq-fe.h... no checking libpq-fe.h presence...

Why can't alcohols form hydrogen-bonded dimers like carboxylic acids? I have never worked with it and I run into a couple of problems to get it running. Join them; it only takes a minute: Sign up pg gem install fails, cannot find libpq-fe.h header up vote 7 down vote favorite 1 Whenever I run bundle install on my share|improve this answer answered Jan 12 '12 at 6:52 David Pelaez 778811 2 David's solution worked for me.

At the end of the output, the following lines were outputted: checking libpq-fe.h usability... https://github.com/rstats-db/RPostgres/issues/21 Thus I installed it using and app from PostreSQL main website. Sign in to comment Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc. share|improve this answer edited Aug 31 '15 at 13:19 answered Aug 29 '15 at 9:39 Jens 2,26532037 add a comment| up vote 0 down vote Finally solved this problem.

How to challenge optimized player with Sharpshooter feat Physically locating the server Is there a way to prevent developers from using std::min, std::max? http://oncarecrm.com/error-cannot/error-cannot-find-libmilter.html Catalan Indonesian Russian Spanish Simplified Chinese Greek Brazilian Portuguese English Hi there! Hot Network Questions Is there a word in Esperanto for "lightsaber"? Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

For example, with the 9.4 release (current as of this writing), all you need is: export CONFIGURE_ARGS="with-pg-include=/Applications/Postgres.app/Contents/Versions/9.4/include" gem install pg This will keep your pg gem in sync with exactly the postgis postgresql installation ubuntu share|improve this question asked Apr 24 '13 at 20:29 VanCity 1515 add a comment| 5 Answers 5 active oldest votes up vote 0 down vote accepted A I installed Postgresql via EnterpriseDB's grapihcal installer. http://oncarecrm.com/error-cannot/error-cannot-find.html Vertical align top in multicolumn Draw an ASCII chess board!

yes checking libintl.h presence... Still if you are not able to resolve, please drop your concern in comments. krlmlr reopened this Nov 21, 2015 krlmlr commented Nov 21, 2015 Thanks.

asked 3 years ago viewed 2697 times active 3 years ago Related 2Can't install libopenssl-ruby4Passenger (mod-rails) can't find libopenssl-ruby2Error while installing rails1Error Installing ruby-rvm1Could not find a valid gem 'rails' (>=

Hierarchy: previous post , next post Please enable JavaScript to view the comments powered by Disqus. ERROR:  Error installing pg: ERROR: Failed to build gem native extension. /Users/username/.rvm/rubies/ruby-2.0.0-p247/bin/ruby extconf.rb checking for pg_config... So, make sure of your pg version before including the libs. Installing something from homebrew is a waste in this case.

Also, I am no longer using a mac. I followed the instructions for installing PostGIS on this webpage: http://postgis.net/docs/manual-2.0/postgis_installation.html Section 2.4.1 ("Configuration") on this webpage tells me to type "./configure". Then bundle install worked for me. his comment is here If building fails, please try again with --with-pg-config=/path/to/pg_config checking for libpq-fe.h...

The bundler config is stored in ~/.bundle/config, so it will not be found if you run bundle config while logged-in as root, but bundler is being run by (e.g. dckc commented Feb 2, 2016 pkg-config is everywhere, in my experience, though perhaps pg_config is to be found wherever the postgres headers are found googlecounts: pkg-config: About 540,000 results pg_config: About krlmlr closed this Nov 10, 2015 dckc commented Nov 19, 2015 I'm using SLES 11, and I get the same symptoms. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed

Browse other questions tagged centos capistrano bundler pg centos7 or ask your own question. I am now trying to install PostGIS, which is an extension to PostgreSQL used for Geographical Information Systems capabilities. I symlinked the pg_* scripts into the path like so: ln -s /usr/pgsql-9.3/bin/p* /usr/local/bin. yes checking for msgfmt... /usr/bin/msgfmt checking for dcgettext...

yes checking for gcc option to accept ISO C89... Since it was a large change, I've closed #73 and would suggest referencing this thread against #81. Sign up for free to join this conversation on GitHub. GNU checking for gcc...